Z3MCoupe.com Forums

Go Back   Z3MCoupe.com Forums > M Coupé Technical > Technical Discussion
HOME Gallery Register Members List Calendar Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
  #1  
Old 28-07-2014, 04:42 PM
Dave P's Avatar
Dave P Dave P is offline
Administrator
 
Join Date: Dec 2008
Location: Cheshire
Posts: 21,022
Default For those with BBK

My ABS doesn't work since fitting 4 pot calipers and bigger discs has anyone else with different brakes to standard had the same problem?
(no faults showing with the ABS system)
__________________
Reply With Quote
  #2  
Old 28-07-2014, 08:10 PM
Bruski_11 Bruski_11 is offline
Senior Member
 
Join Date: Mar 2010
Location: London
Posts: 503
Default

hey Dave, does it help if I say "no"?

Something I checked with the garage before I drove off, along the lines of "simple question, the ABS still works right?"

No warnings and have done a manual test as well, still works.
Reply With Quote
  #3  
Old 28-07-2014, 08:45 PM
Dave P's Avatar
Dave P Dave P is offline
Administrator
 
Join Date: Dec 2008
Location: Cheshire
Posts: 21,022
Default

Quote:
Originally Posted by Bruski_11 View Post
hey Dave, does it help if I say "no"?

Something I checked with the garage before I drove off, along the lines of "simple question, the ABS still works right?"

No warnings and have done a manual test as well, still works.
Good to hear that yours works so mine needs further investigation
__________________
Reply With Quote
  #4  
Old 29-07-2014, 11:09 AM
c_w's Avatar
c_w c_w is offline
Moderator
 
Join Date: Aug 2005
Location: North West
Posts: 8,249
Default

What is making you think it doesn't work properly? It will be slightly affected I think by the change in brake performance from stock.
Reply With Quote
  #5  
Old 29-07-2014, 02:10 PM
Dave P's Avatar
Dave P Dave P is offline
Administrator
 
Join Date: Dec 2008
Location: Cheshire
Posts: 21,022
Default

Quote:
Originally Posted by c_w View Post
What is making you think it doesn't work properly? It will be slightly affected I think by the change in brake performance from stock.
The front left locks up under very hard braking but the ABS doesn't kick in
__________________
Reply With Quote
  #6  
Old 29-07-2014, 08:08 PM
fastdrive fastdrive is offline
Senior Member
 
Join Date: Sep 2004
Location: italy
Posts: 919
Send a message via MSN to fastdrive
Default

i had stoptech from 5 years,best mod ever..the abs work fine.
__________________
www.fastdrive.org
S50 black/black-red In Rome
Front BBK Stoptech Red+Eibach Sway Bars+Kw Clubsport Whit Camber plates+Weichers Strutbar+Agk Urethane front Silent Block & differential Bushing+Tuner Motorposrt Alluminium Rear Mount+Hamann Exaust
Reply With Quote
  #7  
Old 29-07-2014, 08:20 PM
c_w's Avatar
c_w c_w is offline
Moderator
 
Join Date: Aug 2005
Location: North West
Posts: 8,249
Default

Seems a bit strange, normally light would be on with a fault (or at a least a sensor fault).
Reply With Quote
  #8  
Old 31-07-2014, 06:36 AM
ragerover's Avatar
ragerover ragerover is offline
Senior Member
 
Join Date: May 2007
Location: newcastle upon tyne
Posts: 2,972
Default

Dave common fault on BMW`s iirc its an airlock in the pump which causes a sticky valve

a tap with a rubber mallet sometimes cures it
__________________
[GROWING OLD IS COMPULSARY ---- GROWING UP IS OPTIONAL
Reply With Quote
  #9  
Old 31-07-2014, 07:51 PM
Dave P's Avatar
Dave P Dave P is offline
Administrator
 
Join Date: Dec 2008
Location: Cheshire
Posts: 21,022
Default

Cleaned all four ABS sensors and it now works



__________________
Reply With Quote
  #10  
Old 01-08-2014, 12:05 PM
KnightsG KnightsG is offline
Senior Member
 
Join Date: Apr 2014
Posts: 556
Default

What kit are you using there Dave, glad all is sorted.
Reply With Quote
Reply

Tags
abs

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 02:05 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.