Z3MCoupe.com Forums

Go Back   Z3MCoupe.com Forums > M Coupé Technical > Technical Discussion
HOME Gallery Register Members List Calendar Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
  #11  
Old 31-07-2006, 03:25 PM
KIDDLE KIDDLE is offline
Senior Member
 
Join Date: Oct 2004
Location: Windsor
Posts: 167
Default

Just had mine fixed under EW ... was the MAF, changed it on the car (S54) and now she is perfect !
__________________
Need help setting up a CMMS/EAMS system?
S54: P*** Yellow ;-)
Reply With Quote
  #12  
Old 24-08-2006, 10:38 AM
Brett Brett is offline
Senior Member
 
Join Date: Mar 2006
Location: Fife, Scotland
Posts: 159
Default

Quote:
Originally Posted by David1975
Hi Outrun,

have you had any closure on your idling problem?

cheers

David
Nope - he has sold the car to me and I have now experienced it first hand.

Drove to the airport on Tuesday morning - car started at "normal" revs at home. Pulled into the car park where the revs stuck at about 1300 rpm. Blipped the throttle, but no joy. Didn't have time to try work it out, so turned off and got my flight. Got back last night, turned the key - revs shot up to 1600 initially, blipped the throttle and they settled to around 1300 again. Left for home. Got the the queues at the Forth Road Bridge and "normal" idling had resumed.

I've not had a chance to look under the bonnet yet, but I am wondering whether a "sticking" throttle cable might be the cause? I don't know what the throttle mechanism is on the S50, but I had a similar problem on an old Corvette that I used to have and that turned out to be the cause.

Any thoughts anyone?
__________________
CLK55 AMG Cabriolet

ex Estoril Blue Z3M Coupe
Reply With Quote
  #13  
Old 03-10-2006, 09:11 PM
Brett Brett is offline
Senior Member
 
Join Date: Mar 2006
Location: Fife, Scotland
Posts: 159
Default

Hmmm....I know I am probably clutching at straws here but last two tankfuls have been V Power (or whatever Optimax is called now) and problem is worse than ever. Prior to that, I've been using BP's Ultimate unleaded and things were fine on the whole. Will switch back when I next need to fill the tank and will report back. Very smooth under acceleration but lumpy/irregular idling :?:
__________________
CLK55 AMG Cabriolet

ex Estoril Blue Z3M Coupe
Reply With Quote
  #14  
Old 04-10-2006, 01:51 PM
biggusladdus biggusladdus is offline
Junior Member
 
Join Date: Feb 2006
Location: Staffs
Posts: 13
Default

Is it just a problem at idle?

I had a similar sounding problem with my e36 328. When I changed gear and released the throttle, the revs would stay up where they were for a while, and when they did fall, it was all of a sudden with a bit of a 'jerk'. The revs sometimes climbed up by themselves when I was sitting in traffic.

I took the car to an indy to have a diagnostics check done, and it was the potentiometer. Changed this and it has been fine ever since.

Total bill including the diagnostics check was less than half thanexcess would be for an extended warranty claim.
Reply With Quote
  #15  
Old 04-10-2006, 03:48 PM
Brett Brett is offline
Senior Member
 
Join Date: Mar 2006
Location: Fife, Scotland
Posts: 159
Default

Quote:
Originally Posted by biggusladdus
Is it just a problem at idle?

I had a similar sounding problem with my e36 328. When I changed gear and released the throttle, the revs would stay up where they were for a while, and when they did fall, it was all of a sudden with a bit of a 'jerk'. The revs sometimes climbed up by themselves when I was sitting in traffic.

I took the car to an indy to have a diagnostics check done, and it was the potentiometer. Changed this and it has been fine ever since.

Total bill including the diagnostics check was less than half thanexcess would be for an extended warranty claim.
Yeah the problem only appears at idle and is pretty much as described at the top of this message. Outrun did have the potentiometer replaced but the issue appears to have returned. I'll have to get it back in for a check and see what they come up with.
__________________
CLK55 AMG Cabriolet

ex Estoril Blue Z3M Coupe
Reply With Quote
  #16  
Old 14-10-2006, 11:44 PM
Brett Brett is offline
Senior Member
 
Join Date: Mar 2006
Location: Fife, Scotland
Posts: 159
Default

I took the car into BMW to have a look at - they test drove the car and witnessed the high idling. They suggested they would need to bring it in for diagnostics and that might take up to three days to complete. I couldn't spare the car over the past couple of weeks, so it hasn't been in.

What I did do, however, was read the manual and note that it recommended 95RON fuel for M powered Coupes. So the last three tanks have been 95RON rather than Optimax or V Power and the idle problem and shuddering has completely disappeared. I've done a good 500 miles without incident in all kinds of weather barring snow/ice but give it a month...
__________________
CLK55 AMG Cabriolet

ex Estoril Blue Z3M Coupe
Reply With Quote
  #17  
Old 16-10-2006, 11:37 AM
David1975's Avatar
David1975 David1975 is offline
Senior Member
 
Join Date: Feb 2006
Location: Teesside
Posts: 681
Default

Brett, Glad to hear its solved the problem but my manual and sticker on fuel gauage recomemnds 98 Ron Fuel for my S50??

Was it the owners manual you were reading?

cheers

Dave
__________________
EX: S50 Black with Kyalami Orange/Black Leather. Becker Bluetooth/Ipod HU.
Now: S50 Black/Black with Ap Racing brakes and Race logic
Reply With Quote
  #18  
Old 16-10-2006, 12:32 PM
BEN's Avatar
BEN BEN is offline
Senior Member
 
Join Date: Oct 2004
Posts: 5,431
Default

Quote:
Originally Posted by David1975
.............Was it the owners manual you were reading?

cheers

Dave
maybe one off an old sierra!
Reply With Quote
  #19  
Old 16-10-2006, 12:48 PM
Brett Brett is offline
Senior Member
 
Join Date: Mar 2006
Location: Fife, Scotland
Posts: 159
Default

Quote:
Originally Posted by BEN
Quote:
Originally Posted by David1975
.............Was it the owners manual you were reading?

cheers

Dave
maybe one off an old sierra!
I'll double check but it was the owners manual that came with the car! I'm sure it said BMW on the outside rather than Sierra, but having worked the weekend from hell, I could be mistaken :shock:
__________________
CLK55 AMG Cabriolet

ex Estoril Blue Z3M Coupe
Reply With Quote
  #20  
Old 16-10-2006, 04:18 PM
Brett Brett is offline
Senior Member
 
Join Date: Mar 2006
Location: Fife, Scotland
Posts: 159
Default

Well I double checked today - the manual definitely says "BMW Z3" on the front. On page 26 under fuel grade it says 91RON for 2.8 and 3.0 engines and M engines 95RON. I also looked in the fuel filler cap and it says 95-98RON.
__________________
CLK55 AMG Cabriolet

ex Estoril Blue Z3M Coupe
Reply With Quote
Reply

Tags
idle, maf

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 11:17 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2018, vBulletin Solutions, Inc.