Z3MCoupe.com Forums

Go Back   Z3MCoupe.com Forums > M Coupé Technical > Technical Discussion
HOME Gallery Register Members List Calendar Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
  #1  
Old 25-06-2011, 03:22 PM
Dave Mallon Dave Mallon is offline
Senior Member
 
Join Date: Feb 2010
Location: Manchester UK
Posts: 178
Default Idle issues

Hi.

Car generally idles at 800 rpm. Occasionally and more often it's been idling
At 1500 rpm. Not after start but when I've done a few miles and the engines warm.
The cars not lost a drop of oil. Temp , sits about 90 degrees and rock steady no matter what type if driving I'm doing. 29,000 miles. S50.

Any thoughts?

Dave
Reply With Quote
  #2  
Old 25-06-2011, 03:28 PM
Fat Tony Fat Tony is offline
Moderator
 
Join Date: Jul 2009
Location: Leeds(ish)
Posts: 2,053
Default

Ha, I just about to post about mine doing the same. Read a couple of threads on here about a missing cap on a t-piece beneath the air box. Haven't had a chance to have a nosey yet, or whether mine features this t-piece or not (having the Simota fitted, rather than OE air box - not sure what the T-piece is part of)
__________________
Not actually in the least bit fat

2000 S50 Titanium Silver / Black
ACS Suspension, Exhaust & Type III Wheels
Simota carbon air intake | Strong Strut Front Brace
Reply With Quote
  #3  
Old 25-06-2011, 03:33 PM
Dave P's Avatar
Dave P Dave P is offline
Administrator
 
Join Date: Dec 2008
Location: Cheshire
Posts: 21,083
Default

could be this problem,

http://www.z3mcoupe.com/forum/showth...ght=rough+idle
__________________
Reply With Quote
  #4  
Old 25-06-2011, 04:16 PM
Dave Mallon Dave Mallon is offline
Senior Member
 
Join Date: Feb 2010
Location: Manchester UK
Posts: 178
Default

Yeah, I'll take a look at that when I get chance.
The engine is running really smooth at idle and not hunting, just idling too fast!
Reply With Quote
  #5  
Old 25-06-2011, 05:24 PM
Fat Tony Fat Tony is offline
Moderator
 
Join Date: Jul 2009
Location: Leeds(ish)
Posts: 2,053
Default

Quote:
Originally Posted by Dave Mallon View Post
The engine is running really smooth at idle and not hunting, just idling too fast!
Ditto. Sorry Dave, I don't mean to crash your thread but seemed daft having 2 running on the same subject

Mine can vary from one idle to the next though. Stop at a set of lights, 700ish, next stop and it may be the same or more like 1100, next set whichever of the two it fancies. Oh and occasionally I'll start it up and it'll jump to around 2000rpm on idle. Blip the throttle a tad and it (usually) drops to 700ish straight away.

Running sweet-as otherwise. Had a great run today. Love driving this motor
__________________
Not actually in the least bit fat

2000 S50 Titanium Silver / Black
ACS Suspension, Exhaust & Type III Wheels
Simota carbon air intake | Strong Strut Front Brace

Last edited by Fat Tony; 25-06-2011 at 05:28 PM.
Reply With Quote
  #6  
Old 25-06-2011, 05:45 PM
kwoffa kwoffa is offline
Moderator
 
Join Date: Apr 2007
Location: Kingswood,Surrey
Posts: 3,197
Default

If anyone needs the cap that goes on the hose ive got one spare!! Brand new!
Reply With Quote
  #7  
Old 25-06-2011, 05:57 PM
ian's Avatar
ian ian is online now
Senior Member
 
Join Date: Nov 2006
Location: New Forest
Posts: 2,001
Default

Throttle cable sticking?
__________________
S54 Titan Silver metallic. Black leather, most factory options including sunroof, Becker Cascade and Becker Silverstone changer.
Reply With Quote
  #8  
Old 29-06-2011, 04:26 PM
brg 990 brg 990 is offline
Member
 
Join Date: Jan 2010
Posts: 94
Default

My idle was erratic too , t piece plug was cracked so I replaced it , also cleaned the air mass meter? As per a thread on here , replaced the air filter too ( actually put the oe filter and box on instead of the simota ). Been fine since
Reply With Quote
  #9  
Old 29-06-2011, 04:28 PM
indy indy is offline
Senior Member
 
Join Date: Aug 2009
Posts: 4,353
Default

does it make any difference that the aircon may be switched on?

my car would behave differently, and would idle higher if the aircon was on! the accel pedal would feel different too (bit of a thump up the backside when letting go?)
__________________

Click here to email me
Reply With Quote
  #10  
Old 30-06-2011, 10:52 PM
Dave Mallon Dave Mallon is offline
Senior Member
 
Join Date: Feb 2010
Location: Manchester UK
Posts: 178
Default

It just runs, 100-200 higher than whatever it decides it wants to do at the time with the aircon on.

Was fine the other night, steady at 800 when I was stationary! Hopefully I'll have time to look at it next week!

Thanks for your replies!
Reply With Quote
Reply

Tags
idle

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 06:45 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.