Z3MCoupe.com Forums

Go Back   Z3MCoupe.com Forums > Z3MCoupé.com Forums > For Sale or Wanted
HOME Gallery Register Members List Calendar Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
  #1  
Old 04-03-2018, 05:00 PM
Knightrider Knightrider is offline
Senior Member
 
Join Date: Aug 2009
Posts: 266
Default Wanted: HK door tweeter/mid

A long shot I know... Looks like my driver's door speakers have blown again - don't suppose anyone has any spares? Part numbers are 65138400389 and 65138400381.
__________________
'99 Imola S50 | Simota | Front strut | Braided clutch cable | Bilstein B8 and H&R springs
Reply With Quote
  #2  
Old 06-03-2018, 11:02 AM
Knightrider Knightrider is offline
Senior Member
 
Join Date: Aug 2009
Posts: 266
Default

I'm guessing that's a no then!

Has anyone replaced their door speakers with something other than stock? The HK speakers seem very unreliable so I am loathed to keep spending £80 per speaker for something that will blow again after a couple of years...
__________________
'99 Imola S50 | Simota | Front strut | Braided clutch cable | Bilstein B8 and H&R springs
Reply With Quote
  #3  
Old 06-03-2018, 01:56 PM
c_w's Avatar
c_w c_w is offline
Moderator
 
Join Date: Aug 2005
Location: North West
Posts: 8,312
Default

Is there something else causing the issue? I've never had any issues with my speakers in my car.
Reply With Quote
  #4  
Old 06-03-2018, 01:59 PM
Seca Blue's Avatar
Seca Blue Seca Blue is offline
Senior Member
 
Join Date: Jan 2005
Location: Suffolk
Posts: 1,684
Send a message via MSN to Seca Blue
Default

I always have issues with mine. THEY ARE CRAP!!!!!!!!!
__________________
S54 Seca Blue - ACS Short shift and Exhaust. Luverly.
Reply With Quote
  #5  
Old 06-03-2018, 04:09 PM
Dave P's Avatar
Dave P Dave P is offline
Administrator
 
Join Date: Dec 2008
Location: Cheshire
Posts: 21,805
Default

Is it a standard headunit or replacement? could it be a wiring fault


https://www.ebay.co.uk/itm/BMW-Z3-ha...rIAAOSw1WJZNwn-
__________________
Reply With Quote
  #6  
Old 06-03-2018, 04:58 PM
Knightrider Knightrider is offline
Senior Member
 
Join Date: Aug 2009
Posts: 266
Default

Thanks - has spotted the mid on ebay, but was just scouting for alternative options first. Aftermarket head unit, but the footwell speaker is working as is the passenger side, so I suspect it is the speakers.

About 3-4 years ago, I spotted that the drivers side wasn't working, and discovered that the drivers mid and both tweeters had gone... Replaced them all but just noticed that they have gone again.
__________________
'99 Imola S50 | Simota | Front strut | Braided clutch cable | Bilstein B8 and H&R springs
Reply With Quote
  #7  
Old 07-03-2018, 08:37 AM
c_w's Avatar
c_w c_w is offline
Moderator
 
Join Date: Aug 2005
Location: North West
Posts: 8,312
Default

I'm sure I read the ohm is an odd figure on these? Perhaps related if you use an aftermarket headunit? Might just be making this up though!
Reply With Quote
  #8  
Old 07-03-2018, 03:19 PM
Knightrider Knightrider is offline
Senior Member
 
Join Date: Aug 2009
Posts: 266
Default

Stock speakers are rated at 4 ohm...
__________________
'99 Imola S50 | Simota | Front strut | Braided clutch cable | Bilstein B8 and H&R springs
Reply With Quote
  #9  
Old 16-04-2018, 11:48 AM
Knightrider Knightrider is offline
Senior Member
 
Join Date: Aug 2009
Posts: 266
Default

Went gremlin chasing yesterday and narrowed this down. Speakers were actually fine, as was the amp. There is a connector under the rubber cover as the wires exit to the door which must have come loose. It is impossible to get the bolt off that holds it unless you remove the door, but I managed to reach the back of it from inside the footwell speaker hole and wiggle the connector back in.

Result!
__________________
'99 Imola S50 | Simota | Front strut | Braided clutch cable | Bilstein B8 and H&R springs
Reply With Quote
  #10  
Old 16-04-2018, 02:38 PM
guido guido is offline
Senior Member
 
Join Date: Nov 2009
Location: UK
Posts: 593
Default

Quote:
Originally Posted by c_w View Post
Is there something else causing the issue? I've never had any issues with my speakers in my car.
playing drum & bass at full volume?...
Reply With Quote
Reply

Tags
speakers

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 12:10 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2018, vBulletin Solutions, Inc.